poj1426:Find The Multiple

总时间限制: 1000ms 内存限制: 65536kB
描述
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
输入
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
输出
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
样例输入

2
6
19
0

样例输出

10
100100100100100100
111111111111111111

题目大概意思:给一个数n,你要求出能够整除这个数的只包含0和1的十进制数,
思路:可以用bfs,最高位是1,其余每一位要么是0,要么是1,就是双入口的Bfs,数可能会很大,用long long表示

代码:

#include<bits/stdc++.h>
using namespace std;
void bfs(int x){
	queue<long long>q;
	q.push(1);
	while(!q.empty()){
	      long long  t=q.front();
	      q.pop();
	      if(t%x==0){
	      	printf("%lld\n",t);
	      	return ;
		  }
		  q.push(t*10);
		  q.push(t*10+1);
	}
}
int main()
{
	int n;
	while(cin>>n&&n){
	     bfs(n);
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值