PAT 甲级 1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码:

#include<stdio.h>
#include<string>
using namespace std;

int main(){
	int a;
	int b;
	while (scanf("%d %d", &a, &b) != -1){
		int sum = a + b;
		string r = to_string(sum);
		int len = r.size();
		for (int i = len - 3;(sum>0?i > 0:i>1); i -= 3){
			r.insert(i, ",");
		}
		printf("%s\n", r.c_str());
	}
	return 0;
}

思路:

1、输入两个数(int类型)后求和,求和后转为字符串类型

2、从后往前遍历字符串,注意终止条件不同

如果和为负数,终止条件为i>1(第0个位置字符为负号,不能在负号后面插入“,”)

如果和为正数,终止条件为 i>0(可以在第一个位置插入“,”)

其他方法:

将求和的结果不用转为字符串,直接三位三位打印,中间用逗号隔开。

易错点:

正数和负数添加逗号时,终止的条件不一样

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值