1015 Reversible Primes

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

素数筛 进制转换 数组越界 1不是素数


#include<iostream>
#include<vector>
#include<math.h>
#include<algorithm>
using namespace std;
int N,D;
bool isNotPrime[1000000]; 
int main()
{    fill(isNotPrime,isNotPrime+1000000,false);
	 for(int i=2;i<50000;i++)
	   for(int j=2;i*j<1000000;j++)
	      isNotPrime[i*j]=true;
	isNotPrime[0]=true;
	isNotPrime[1]=true;
	while(1)
	{   int tmp;
		scanf("%d",&N);
		if(N<0) break;
		tmp=N;
		scanf("%d",&D);
		vector<int> v;
		for(int i=0;;i++)
		{
			if(N==0) break;
			v.push_back(N%D);
			N=N/D;
		}
		int reverse=0;
		for(int i=0;i<v.size();i++)
		{
			reverse+=v[i]*pow(D,v.size()-i-1);
		}
		if(isNotPrime[tmp]==false&&isNotPrime[reverse]==false) printf("Yes\n");
		else
		printf("No\n");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值