1016 Phone Bills

3 篇文章 0 订阅
1 篇文章 0 订阅

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-linerecord. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

思路:用结构体数组存每个用户的通话记录 ,先按照名字排序,后按照通话时长排序(通话时长用time表示,并在输入数据的时候就算出每条信息的time值)

然后将排好序的数组存入map中,一个姓名(key)对应一个数组(value),也可以理解为一个姓名对应多条通话信息;

在存的过程中要注意配对原则,即前一条通话记录的状态应是“on-line” 后一条通话记录的状态应该是“off-line”否则不予以记录;

存好以后遍历map,对于每个单独的key值,遍历对应的value数组;两个两个的遍历,计算出通话时长 和 消费金额

通话时长直接用两者的time值相减;而消费金额则采取特殊做法:分别从00:00:00点到该时间的消费金额,然后两者相减即为在这一段时间内的消费金额

/*
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
*/
#include<iostream>
#include<vector> 
#include<algorithm>
#include<map>
using namespace std;
int cash[24];
int N;
int cnt=0;
struct cus{
	string name;
    int time,month,date,hour,min;
	int status;
};
bool cmp(cus x,cus y)   //结构体排序 
{
	if(x.name!=y.name)
	return x.name<y.name;
	else
	return x.time<y.time;
}
double BillFromZero(int date,int hour,int min) //计算从00:00:00到某个时间点的消费金额 
{
	double sum=0.0;
	sum=cnt*60*date+min*cash[hour];
	for(int i=0;i<hour;i++)
	{
		sum+=cash[i]*60; 
	}
	return sum/100.0;   //因为cash[i]为cent/min,所以要除以100换算成$ 
}
int main()
{   
   	for(int i=0;i<24;i++)
   	{
   		scanf("%d",&cash[i]); 
   		cnt+=cash[i];    
	}
	scanf("%d",&N);
	vector<cus> c(N);
	for(int i=0;i<N;i++)
	{   cin>>c[i].name;
		scanf("%d:%d:%d:%d",&c[i].month,&c[i].date,&c[i].hour,&c[i].min);  //"02"这种类型的可以直接往里录 
		string temp;
		cin>>temp;
		if(temp=="on-line")
		c[i].status=1;
		else
		c[i].status=0;
		c[i].time=c[i].date*24*60+c[i].hour*60+c[i].min;
	}
	sort(c.begin(),c.end(),cmp); 
	map<string,vector<cus> > custom;
	for(int i=1;i<N;i++)
	{
		if(c[i].name==c[i-1].name&&c[i].status==0&&c[i-1].status==1)
	       {
	   	        custom[c[i-1].name].push_back(c[i-1]);
	        	custom[c[i].name].push_back(c[i]);
		   }	
	}
	for(auto it:custom) //迭代器遍历 
	{ vector<cus> v=it.second;  //map中的值 
	  cout<<it.first;//map中的键 
	  printf(" %02d\n",v[0].month);
	  double total=0.0;
	  for(int i=1;i<v.size();i+=2)
	  { double t=BillFromZero(v[i].date,v[i].hour,v[i].min)-BillFromZero(v[i-1].date,v[i-1].hour,v[i-1].min);
	    //%02d表示输出宽度为2的整数,向右对齐,不够用0来补 
	  	printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",v[i-1].date,v[i-1].hour,v[i-1].min,v[i].date,v[i].hour,v[i].min,v[i].time-v[i-1].time,t);
	  	total+=t;
	  }
	  printf("Total amount: $%.2f\n",total);
	} 
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值