1004 Counting Leaves

2 篇文章 0 订阅
2 篇文章 0 订阅

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

思路:用vector二维数组动态存储图的信息,广度搜索找每一层叶子节点的个数。

要注意:当vector刚被创建出来时,vector[i]是非法的,还没有占用空间,因此,如果想要调用vector[i],则应该用vector.resize()来提前开辟空间。


指定二维vector的大小

在对二维vector如
vector< <vector> vec
如果我们使用vec.push_back()是没有问题的。
但是如果使用vec[i].push_back()会出现下标越界。

这是因为此时的vec为空,无论是vec还是vec[i]的size都是0,这个时候取vec[i]会出现下标越界情况。
解决办法是在push_back之前先定义vec的长度,如vec.resize(5);
此时我们就可以使用vec[i].push_back()了,但是vec[i][j]仍然会出现下标越界。
如果想使用vec[i][j],需要同时指定vec和vec[i]的大小,此时用到一个临时一维vector,代码如下:

vector <vector<int> > v1;
vector<int> temp(4)
v1.resize(5,temp)
1
2
3
此时的v1的size为5,v1[i] (0<i<5) 的size为4
--------------------- 
原文链接:https://blog.csdn.net/liuweiyuxiang/article/details/88692708


/*
2 1
01 1 02
*/
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
int N,M;
vector<vector<int> > vec;
int to_int(string c)
{
	    int sum=0;
      	sum=10*(c[0]-'0')+(c[1]-'0');
      	return sum;
}
int main()
{
	scanf("%d%d",&N,&M);
	vec.resize(N+1);   //提前开辟空间,方便对vec[i]的操作
    for(int i=0;i<M;i++)
      { int parent;
	    string p;
        cin>>p;
        parent=to_int(p);
        int count;
        cin>>count;
        for(int j=0;j<count;j++)
            {
            	int child;
            	string c;
            	cin>>c;
				child=to_int(c);
				vec[parent].push_back(child);//如果一个parent节点有子节点则将其动态存入vec数组
			}
	  }
	  queue<int> q;
	  q.push(1); 
	  while(!q.empty())   //当队列非空,循环遍历队列
	  { int len=q.size(); //取队列的长度,每一次循环只遍历树的一层,队列的长度即为此层节点个数
	    int cnt=0;
	    for(int i=0;i<len;i++)
	    {
	    	int t=q.front();q.pop();  //挨个取头结点并出队
	    	if(vec[t].size())        //当此节点有子节点时(子节点都存储在vec[t]数组中)
	    	{
	    		for(int k=0;k<vec[t].size();k++)
	    		{
	    			q.push(vec[t][k]);  //将各个子节点入栈
				}
			}
			else 
			cnt++; //当此节点没有子节点时,cnt++
		}
		cout<<cnt;
		if(!q.empty()) cout<<" "; //当队列非空时,意味着树的遍历还没有结束,则在结果后输出空格
	  }
	
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值