1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains Knumbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

有些测试点很难过,所以需要不断调整算法;初值的设定不好想。。

/*
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
*/ 
#include<iostream>
using namespace std;
const int maxn=10005;
int a[maxn];
int main()
{
	int N;
	scanf("%d",&N);
	int first=0,last=N-1;
	int begin=0;
	int max,thismax=0;
	scanf("%d",&a[0]);
	max=a[0];       //设定max、thismax的初值为a[0];如果设置为0,则不好对付只有负数和0混在一起的测试点 
	thismax=a[0];
	for(int i=1;i<N;i++)
	{
		scanf("%d",&a[i]);
		if(thismax<0)   //如果当前最大值小于0则begin等于i,将当前最大值设置为a[i] 
		{
			begin=i;
			thismax=a[i];
		}
		else
		{   
		   thismax+=a[i];  //如果当前最大值不小于0,则继续累加 
		}
		if(thismax>max)    //如果当前最大值大于原来最大值,使first等于前面记录的begin,last等于当前的i,刷新最大值; 
		{   max=thismax;
			first=begin;
			last=i;
		}
	}
	if(max<0)   //当最大值小于0则数组中肯定都是负数,令最大值为0 
	{
		max=0;
	}
	printf("%d %d %d",max,a[first],a[last]);
}

 不容易过的测试点:

1.都是负数的情况:

3
-1 -2 -3
0 -1 -3

2.只有负数和0的情况:

5
-4 0 -4 0 -5
0 0 0

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值