PAT甲级1130 Infix Expression (25 分)

1130 Infix Expression (25 )

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG

 

infix2.JPG

 

Figure 1

Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

      题目大意:

     给定n个结点的表达树,每一行都是序号为i的 data 左孩子编号 和右孩子编号。编号由1~n。求表达式。

思路:

  用静态二叉树处理,且需要找到根节点,这用一个数组father记录,当某个结点是father[i] == false 那就是根结点。中序表达式用中序遍历,在相应位置加上括号即可,当该结点有左右任一孩子、且不为根节点时就要打印括号了。

         注意root 是从1开始滴。

参考代码:

 

 

 

#include<vector>
#include<cstdio>
using namespace std;
struct node{
	char data[11];
	int l, r;
};
vector<bool> father;
vector<node> t;
int n, root = 1;
void inorder(int v){
	if(v == -1) return;
	if((t[v].l != -1 || t[v].r != -1 ) && v != root) printf("(");
	inorder(t[v].l);
	printf("%s", t[v].data);
	inorder(t[v].r);
	if((t[v].l != -1 || t[v].r != -1 ) && v != root) printf(")");
}
int main(){
	scanf("%d", &n);
	father.resize(n + 1); t.resize(n + 1);
	for(int i = 1; i <= n; ++i){
		scanf("%s %d %d", t[i].data, &t[i].l, &t[i].r);
		if(t[i].l != -1) father[t[i].l] = true;
		if(t[i].r != -1) father[t[i].r] = true;
	}
	while(root <= n && father[root]) root++;
	inorder(root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值