PAT甲级1107 Social Clusters (30 分)

1107 Social Clusters (30 )

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Kihi[1] hi[2] ... hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

 

      题目大意:

         给出n个人的信息,并从1~n进行编号,随后n行每一行都是i的兴趣代号.一个兴趣集被定义为在该集中人们都有某些兴趣是一致的。求所有的兴趣集以及每个兴趣集里面有多少人。

 

 

思路:

         用两个数组,一个是father,用以记录一个兴趣集,另一个是habit,用以标识是否能形成一个兴趣集,只有当habit[j] == 0的时候就让这个habit[j = i,指向当前这个人,那么就有一个兴趣集产生了。无论有没有产生兴趣集,都应该union一下, 因为有可能同一个人即自己新开了一个兴趣集,又隶属于其他人的兴趣集中。

         最后用一个数组root,如果i是兴趣集的老大即findfather(i) == 0,那么root[i]是记录着这个兴趣集的人数的,如果不是老大的时候,就找出老大,向老大报告增加多一个人。即root(findfather(i) ) ++。最后sort一遍,把有数值的都放到前面。

 

参考代码:

 

#include<vector>
#include<cstdio>
#include<algorithm>
using namespace std;
vector<int> father, root;
int findfather(int v){
	if(v == father[v]) return v;
	int f = findfather(father[v]);
	father[v] = f;
	return f;
}
void Union(int a, int b){
	int fa = findfather(a), fb = findfather(b);
	if(fa != fb)	father[fb] = fa;
}
bool cmp(int a, int b){return a > b;}
int n, k, habit[1010], cnt;
int main(){
	scanf("%d", &n);
	father.resize(n + 1), root.resize(n + 1);
	for(int i = 1; i <= n; ++i)	father[i] = i;
	for(int i = 1; i <= n; ++i){
		scanf("%d:", &k);
		int t;
		for(int j = 0; j < k; ++j){
			scanf("%d", &t);
			if(habit[t] == 0)	habit[t] = i;
			Union(i, findfather(habit[t] ));
		}
	}
	for(int i = 1; i <= n; ++i)
		root[findfather(i)]++;
	for(int i = 1; i <= n; ++i)
		if(root[i])	cnt++;
	sort(root.begin(), root.end(), cmp);
	printf("%d\n", cnt);
	for(int i = 0; i < cnt; ++i)
		printf("%d%c", root[i], i != cnt - 1? ' ': '\n');
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/52191082

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值