PAT甲级1108 Finding Average (20 分)

1108 Finding Average (20 )

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

 

      题目大意:

         给出n个数,要求他们的平均数。给出的数不一定是有效的,在[-1000,1000]内的有理数才算是有效,如果是无效的不应该纳入统计,反而应该输出ERROR: xxx is not a legal number, 在最后一行输出The average of x numbers is y, 当x == 0时要特判。结果保留两位小数。

 

思路:

         由于要判断,那么肯定是用string的,然后用sscanf于sprintf进行控制处理。

参考代码:

 

 

#include<cstdio>
#include<cstring>
using namespace  std;
int n, cnt;
char a[50], b[50];
int main(){
	scanf("%d", &n);
	double temp, sum = 0.0;
	for(int i = 0; i < n; ++i){
		scanf("%s", a);
		sscanf(a, "%lf", &temp);
		sprintf(b, "%.2f", temp);
		bool flag = false;
		for(int j = 0;  j < strlen(a); ++j)
			if(a[j] != b[j]) flag = true;
		if(flag || temp > 1000 || temp < -1000)	printf("ERROR: %s is not a legal number\n", a);
		else	sum += temp, cnt++;
	}
	if(cnt == 1)	printf("The average of 1 number is %.2f", sum);
	else if(cnt > 1)	printf("The average of %d numbers is %.2f", cnt, sum / cnt);
	else	printf("The average of 0 numbers is Undefined");
	return 0; 
}

代码参考:https://blog.csdn.net/liuchuo/article/details/51985816

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值