PAT (Advanced Level) Practice 1129 Recommendation System (标记+排序)

1.题目

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

2.题目分析

经过5、6次方法更新,终于不超时!不爆内存!了!

思路:首先使用vector<node>mark(n + 1);来记录商品的index以及它的次数,开始是直接对mark进行排序——必超时

之后想着用vector<int>time[k+1](伪代码描述),就是0~N个vector,代表次数,每个vector大小最大为K+1,记录index,后面不说了——超时

最后想到其实只需要维护一个大小为K的set来记录要输出的数据,加上使用vector<node>mark(n + 1);来记录商品的index以及它的次数就ok(可谁曾想只要是set,大小超过K也行?我???)

3.代码

未维护大小为K:

#include<iostream>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;
struct  node
{
	int index;
	int times;
}nn;
struct cmp {
	bool operator()(const node &a, const node &b)
	{
		return a.times == b.times ? a.index<b.index : a.times>b.times;
	}
};
int main()
{
	int n, k,t;
	scanf("%d %d", &n, &k);
	set<node,cmp>time;
	vector<node>mark(n + 1);
	for (int i = 1; i <= n; i++)
	{
		scanf("%d", &t);
		if(i!=1)printf("%d:", t);
		int amount = 0;
		for (auto it = time.begin(); it != time.end(); it++)
		{
			if (amount == k)break;
			printf(" %d", *it); amount++;
		}
		if (mark[t].times == 0)
		{
			nn.index = t; nn.times = 1;
			mark[t] = nn;
		}
		else
		{
			time.erase(mark[t]);
			mark[t].times++;
		}
		time.insert(mark[t]);
		if(i!=1)printf("\n");
	}

}

可以看到内存险过

维护大小为K:

#include<iostream>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;
struct  node
{
	int index;
	int times;
}nn;
struct cmp {
	bool operator()(const node &a, const node &b)
	{
		return a.times == b.times ? a.index<b.index : a.times>b.times;
	}
};
int main()
{
	int n, k,t;
	scanf("%d %d", &n, &k);
	set<node, cmp>time;
	vector<node>mark(n + 1);
	for (int i = 1; i <= n; i++)
	{
		scanf("%d", &t);
		if(i!=1)printf("%d:", t);
		int amount = 0;
		for (auto it = time.begin(); it != time.end(); it++)
		{
			if (amount == k)break;
			printf(" %d", *it); amount++;
		}
		if (mark[t].times == 0)
		{
			nn.index = t; nn.times = 1;
			mark[t] = nn;
		}
		else
		{
			time.erase(mark[t]);
			mark[t].times++;
		}
		time.insert(mark[t]);
		if (time.size() > k)//维护大小为K
		{
			auto it = time.end(); it--;
			time.erase(*it);
		}
		if(i!=1)printf("\n");
	}

}

 

可以看到对内存使用的改善效果还ok~ 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值