PAT (Advanced Level) Practice 1013 Battle Over Cities (25分) (使用DFS对图的强连通分量的统计)

1.题目

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

2.题目分析

参考https://www.liuchuo.net/archives/2346

添加的最少的路线,就是他们的连通分量数-1,因为当a个互相分立的连通分量需要变为连通图的时候,只需要添加a-1个路线,就能让他们相连。所以这道题就是求去除了某个结点之后其他的图所拥有的连通分量数

3.代码

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int visited[1010];
int edges[1010][1010];
int n, m, k, a, b, c;
void DFS(int v)
{
	visited[v] = 1;
	for (int i = 1; i <= n; i++)
	{
		if (visited[i] == 0&&edges[v][i]==1)
			DFS(i);
	}
}
int main()
{
	scanf("%d %d %d", &n, &m, &k);
	for (int i = 1; i <= m; i++)
	{
		scanf("%d %d", &a, &b);
		edges[a][b] = edges[b][a] = 1;
	}
	for (int i = 1; i <= k; i++)
	{
		int count = 0;
		fill(visited, visited + 1010, 0);
		scanf("%d", &c);
		visited[c] = 1;
		for (int j = 1; j <= n; j++)
		{
			if (visited[j] == 0)
			{
				DFS(j);
				count++;
			}
		}
		printf("%d\n", count - 1);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值