1046 Shortest Distance (20 分)

36 篇文章 0 订阅
32 篇文章 0 订阅

1046 Shortest Distance (20 分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
​5
​​ ]), followed by N integer distances D
​1
​​ D
​2
​​ ⋯ D
​N
​​ , where D
​i
​​ is the distance between the i-th and the (i+1)-st exits, and D
​N
​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
​4
​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10
​7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=100005;
int dis[maxn],A[maxn];/*dis数组作为 记录1节点顺时针到i+1节点的距离,A数组作为记录i到i+1节点的距离;*/ 
int main(){
	 int sum=0,query,n,left,right;/*小心可能会出现left大于right的情况出现*/ 
	 scanf("%d",&n);
	 for(int i=1;i<=n;i++){
	 	scanf("%d",&A[i]);
	 	sum+=A[i];
		 dis[i]=sum; 
	 }
	 scanf("%d",&query);
	 for(int i=0;i<query;i++){
	 	scanf("%d%d",&left,&right);
	 	if(left>right)swap(left,right);
	 	int temp=dis[right-1]-dis[left-1];
	 	printf("%d\n",min(temp,sum-temp));/*判断两条路那一条短,就选择那一条 */
	 }
	  return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值