02-线性结构4 Pop Sequence (满分)

题目如下

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

思路上整体不难,只需要模拟入栈出栈的操作,如果出现错误栈满,或者pop出的数字不符合所给序列,则说明该序列不可做到。

对于每一条test序列,都可以执行如下判断

s < test_j
s == test_j
s > test_j
Pop == test_j
Pop != test_j
stack->top=-1,s=1,j=0
s与test_j比大小
Push s,s++,j--
Push s,Pop,s++
Pop
j++
NO

同时在Push时如果栈满,则也判断为NO,一个test序列数字全部判断完没有No,则为YES

代码如下

#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
#include<stdlib.h>

struct StackNode
{
	int data[1000];
	int top;
};

typedef struct StackNode* Stack;

int Push(int m,int dat,Stack s)
{
	if (s->top == m - 1)
	{
		return 0;
	}
	else
	{
		s->data[++(s->top)] = dat;		
		return 1;
	}
}

int Pop(Stack s)
{
	int outdata;
	if (s->top == -1)
	{
		return 0;
	}
	else
	{
		outdata = s->data[s->top];
		--s->top;
		return outdata;
	}
}


int main()
{
	int m, n, k;
	int tast[1000][1000];	//这里申请了较大的堆栈空间,vs下需要修改堆栈保留大小
	int i,j;
	scanf("%d%d%d", &m, &n, &k);
	for(i=0;i<k;i++)
		for (j = 0; j < n; j++)
		{
			scanf("%d", &tast[i][j]);
		}

	struct StackNode sstack;
	Stack stack = &sstack;
	stack->top = -1;

	int s = 1;
	int y;
	for (i = 0; i < k; i++)
	{

		s = 1;
		stack->top = -1;
		for (j = 0; j < n; j++)
		{
			//进行判断
			if (s < tast[i][j])
			{
				y = Push(m, s, stack);
				if (y == 0)
				{
					printf("NO\n");
					break;
				}
				++s;
				--j;
			}

			else if (s == tast[i][j])
			{
				y = Push(m, s, stack);
				if (y == 0)
				{
					printf("NO\n");
					break;
				} 
				y = Pop(stack);
				if (y == 0)
				{
					printf("NO\n");
					break;
				}
				++s;
			}


			else if (s > tast[i][j])
			{
				y = Pop(stack);
				if (y == 0)
				{
					printf("NO\n");
					break;
				}
				if (y != tast[i][j])
				{
					printf("NO\n");
					break;
				}
			}

			if (j == n - 1 && s == n + 1)
			{
				printf("YES\n");
			}

		}
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值