PAT Advanced—1015 Reversible Primes (20分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

思路:
  一开始题目看不懂,原来prime是素数的意思,看来自己英语太差了。题目意思是一个数在相应的进制下是素数,它在该进制下的相反数也是素数,输出Yes,否则输出No。题目主要考察进制的转换和素数的判断,比较简单。

注意:

  1. 1不是素数!

代码:(C++)

#include<iostream>
#include<cmath>
#include<vector>
#include<algorithm>

using namespace std;

bool checkPrime(int n)
{
    if(n <= 1)
        return false;
    for(int i=2; i<=sqrt(n); i++)
    {
        if(n%i == 0)
            return false;
    }
    return true;
}

int reverseRadix(int n, int d)
{
    vector<int> site;
    for(int i=0; n!=0; i++)
    {
        site.push_back(n%d);
        n = n / d;
    }
    reverse(site.begin(),site.end());
    int x = 0;
    for(int i=0; i<site.size(); i++)
    {
        x += site[i]*pow(d,i);
    }
    return x;
}

int main()
{
    int n,d;
    while(1)
    {
        cin>>n;
        if(n>0)
            cin>>d;
        else
            break;
        if(checkPrime(n) && checkPrime(reverseRadix(n,d)))
            printf("Yes\n");
        else
            printf("No\n");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值