PAT Advanced—1154 Vertex Coloring (25分)

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.
Now you are supposed to tell if a given coloring is a proper k-coloring.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.
Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:
4-coloring
No
6-coloring
No

题目大意:

  1. 图中,没有两个顶点有相同的边和相同的点颜色,最多使用k中颜色,现在判断给的颜色是否符合顶点k颜色。
  2. 首先给出N个顶点(顶点从0-N-1表示)和M条边,然后给出K个需要去检查的颜色集。如果给出的图满足不重复颜色,就输出有多少颜色,否则输出No

思路:

  1. 保存每个边的结点情况,判断是否有连个边顶点相同,直接枚举判断。
    用map来存顶点与颜色的关系
  2. set来计数

注意:

  1. 这题主要要理解题目意思,实现起来比较容易
  2. 要注意大量数据的输入输出时,最好用scanf和printf

代码:(C++)
代码1:测试点2超时

#include<iostream>
#include<map>
#include<vector>
#include<set>

using namespace std;

map<int,int> v;

struct edge
{
	int a;
	int b;
};

int main()
{
	int N,M,K;
	cin>>N>>M;
	vector<edge> e(N);
	for(int i=0; i<M; i++)
		cin>>e[i].a>>e[i].b;
	cin>>K;
	for(int i=0; i<K; i++)
	{
		set<int> c;  //颜色数量
		for(int j=0; j<N; j++)
		{
			cin>>v[j];
			c.insert(v[j]);
		}
			
		int flag = 0;
		for(int j=0; j<M; j++)
		{
			if(v[e[j].a] == v[e[j].b])
			{
				flag = 1;
				printf("No\n");
				break;
			}
		}
		if(flag == 0)
			cout<<c.size()<<"-coloring\n";
	}
	return 0;
}

代码2:将输入输出改为scanf和printf

#include<iostream>
#include<map>
#include<vector>
#include<set>

using namespace std;

map<int,int> v;

struct edge
{
	int a;
	int b;
};

int main()
{
	int N,M,K;
	cin>>N>>M;
	vector<edge> e(N);
	for(int i=0; i<M; i++)
		scanf("%d %d",&e[i].a, &e[i].b);
	cin>>K;
	for(int i=0; i<K; i++)
	{
		set<int> c;  //颜色数量
		for(int j=0; j<N; j++)
		{
			cin>>v[j];
			c.insert(v[j]);
		}
			
		int flag = 0;
		for(int j=0; j<M; j++)
		{
			if(v[e[j].a] == v[e[j].b])
			{
				flag = 1;
				printf("No\n");
				break;
			}
		}
		if(flag == 0)
			printf("%d-coloring\n",c.size());
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值