PAT Advanced—1154 Vertex Coloring (25分)

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.
Now you are supposed to tell if a given coloring is a proper k-coloring.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.
Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:
4-coloring
No
6-coloring
No

题目大意:

  1. 图中,没有两个顶点有相同的边和相同的点颜色,最多使用k中颜色,现在判断给的颜色是否符合顶点k颜色。
  2. 首先给出N个顶点(顶点从0-N-1表示)和M条边,然后给出K个需要去检查的颜色集。如果给出的图满足不重复颜色,就输出有多少颜色,否则输出No

思路:

  1. 保存每个边的结点情况,判断是否有连个边顶点相同,直接枚举判断。
    用map来存顶点与颜色的关系
  2. set来计数

注意:

  1. 这题主要要理解题目意思,实现起来比较容易
  2. 要注意大量数据的输入输出时,最好用scanf和printf

代码:(C++)
代码1:测试点2超时

#include<iostream>
#include<map>
#include<vector>
#include<set>

using namespace std;

map<int,int> v;

struct edge
{
	int a;
	int b;
};

int main()
{
	int N,M,K;
	cin>>N>>M;
	vector<edge> e(N);
	for(int i=0; i<M; i++)
		cin>>e[i].a>>e[i].b;
	cin>>K;
	for(int i=0; i<K; i++)
	{
		set<int> c;  //颜色数量
		for(int j=0; j<N; j++)
		{
			cin>>v[j];
			c.insert(v[j]);
		}
			
		int flag = 0;
		for(int j=0; j<M; j++)
		{
			if(v[e[j].a] == v[e[j].b])
			{
				flag = 1;
				printf("No\n");
				break;
			}
		}
		if(flag == 0)
			cout<<c.size()<<"-coloring\n";
	}
	return 0;
}

代码2:将输入输出改为scanf和printf

#include<iostream>
#include<map>
#include<vector>
#include<set>

using namespace std;

map<int,int> v;

struct edge
{
	int a;
	int b;
};

int main()
{
	int N,M,K;
	cin>>N>>M;
	vector<edge> e(N);
	for(int i=0; i<M; i++)
		scanf("%d %d",&e[i].a, &e[i].b);
	cin>>K;
	for(int i=0; i<K; i++)
	{
		set<int> c;  //颜色数量
		for(int j=0; j<N; j++)
		{
			cin>>v[j];
			c.insert(v[j]);
		}
			
		int flag = 0;
		for(int j=0; j<M; j++)
		{
			if(v[e[j].a] == v[e[j].b])
			{
				flag = 1;
				printf("No\n");
				break;
			}
		}
		if(flag == 0)
			printf("%d-coloring\n",c.size());
	}
	return 0;
}
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像析等应用至关重要。以下是深度学习的一些关键概念和组成部: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值