【P1531】I Hate It - 洛谷 单点更新板子题

#include <stdio.h>
#include <algorithm>
using namespace std;
#define maxn 200010 
#define ls o<<1
#define rs o<<1|1
int a[maxn];
struct node{
	int l,r,x;
}t[maxn<<2];
inline void push_up(int o){
	t[o].x=max( t[ls].x,t[rs].x);
}
void build(int l,int r,int o)
{
	t[o].l=l,t[o].r=r;
	if(l==r) {
		t[o].x=a[l];return;
	}
	int mid=(l+r)>>1;
	build(l,mid,ls);build(mid+1,r,rs);
	push_up(o); 
}
inline void update(int s,int o,int x)
{
	if(t[o].l==t[o].r&&t[o].l==s)
	{
		t[o].x=x;return;
	}
	int mid=(t[o].l+t[o].r)>>1;
	if(s<=mid) update(s,ls,x);
	else update(s,rs,x);
	push_up(o);
}
inline int query(int l,int r,int o)
{
	if(t[o].l>=l&&t[o].r<=r) return t[o].x;
	int mid=(t[o].l+t[o].r)>>1;
	int ans=0;
	if(r<=mid)  ans=max(ans,query(l,r,ls));
	else if(l>mid) ans=max(ans,query(l,r,rs));
	else {
		ans=max(ans,max(query(l,mid,ls),query(mid+1,r,rs)));
	}
	return ans;
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
	}
	build(1,n,1);
	char op[10];
	int c,b;
	for(int i=1;i<=m;i++)
	{
		scanf("%s%d%d", op,&c,&b);
		if(op[0]=='Q')
		{
			printf("%d\n",query( c,b,1));
		}
		else 
		{
			update(c,1,b);
		}
		
	}
	}
	return 0;
	
}

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。 
这让很多学生很反感。 

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。 
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。 
学生ID编号分别从1编到N。 
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。 
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。 
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。 
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。 

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9


        
  

Hint

Huge input,the C function scanf() will work better than cin
        
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值