LightOJ - 1341(算术基本原理)

题解:需要素数打表否则会超时。。。。

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

#include<stdio.h>
#include<map>
#include<algorithm>
#include<math.h>
using namespace std;
#define maxn 1100000
typedef long long ll;
int pri[maxn];
int primm[maxn];
void prim()//素数打个表否则会超时 
{
	pri[1]=1;
	for(int i=2;i*i<=maxn;i++)
	{
		if(!pri[i])
		{
			for(int j=i*i;j<=maxn;j+=i)
			{
				pri[j]=1;
			}
		}
	}
}
int main()
{
	int T;
	scanf("%d",&T);
	prim();
	ll k=0;
	for(int i=2;i<maxn;i++)
	{
		if(pri[i]==0)
		primm[k++]=i;
	}
	for(int j=1;j<=T;j++)
	{
		ll n,a;
		scanf("%lld%lld",&n,&a);
		ll w=n; 
		if(a>=sqrt(n)) 
		{
			printf("Case %d: 0\n",j);
			continue;
		}
		int num=0;
		ll ans=1;
		for(ll i=0;i<k;i++)
		{
			int tt=0;
			while(w%primm[i]==0)
			{
				w=w/primm[i];
				tt++;
			}
		    ans=ans*(tt+1);
		    if(w==1) break;
		}
		if(w>1) ans*=2;
		ans=ans/2;
		
		for(ll i=1;i<a;i++)
		{
			if(n%i==0)
			{
				ans--;
			}
		}
		printf("Case %d: %lld\n",j,ans);
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值