Hello Kiki(中国剩余定理不互质)

自己写总是有点问题,

当n==1时,且a[i]=0(余数)时应该返回m[0];这应该注意

Problem Description

One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.

 

 

Input

The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

 

 

Output

For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.

 

 

Sample Input

 

2 2 14 57 5 56 5 19 54 40 24 80 11 2 36 20 76

 

 

Sample Output

 

Case 1: 341 Case 2: 5996

#include<stdio.h>
typedef long long ll;
ll m[10],a[10];
ll ex_gcd(ll a,ll b,ll &x,ll &y)
{
	if(b==0)
	{
		x=1;
		y=0;
		return a;
	}
	ll r=ex_gcd(b,a%b,x,y);
	ll t=x;
	x=y;
	y=t-a/b*y;
	return r;
}
ll CRT(int n)
{
	if(n==1)
	{
		if(m[0]>a[0]) return a[0]==0?m[0]:a[0];//这里注意 
		else return -1;
	}
	ll x,y,d;
	for(int i=1;i<n;i++)
	{
		if(m[i]<=a[i]) return -1;
		d=ex_gcd(m[0],m[i],x,y);
		if((a[i]-a[0])%d!=0) return -1;
		ll t=m[i]/d;
		x=((a[i]-a[0])/d*x%t+t)%t;
		a[0]=x*m[0]+a[0];
		m[0]=m[0]*m[i]/d;
		a[0]=(a[0]%m[0]+m[0])%m[0];
	}
	if(a[0]<=0) a[0]+=m[0];//这里 
	return a[0];
}
int main()
{
	int t;
	scanf("%d",&t);
	int k=1;
	while(t--)
	{
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%lld",&m[i]);
		}
		for(int i=0;i<n;i++)
		{
			scanf("%lld",&a[i]);
		}
		ll w=CRT(n);
		printf("Case %d: %lld\n",k++,w);
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值