PAT甲级-1107-Social Clusters(并查集)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i: h​i[1] h​i[2] ... h​i​​ [K​i]

where K​i(>0) is the number of hobbies, and h​i[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

代码如下

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>Arry,isRoot;
int hobby[1005] = {0};
int cmp(int a,int b){
	return a > b;
}
int Find(int num)
{
	int root = num,temp;
	while(Arry[root] != root){//Arry[i]=j表示i的前驱是j,当Arry[i]=i时表示i是根结点
		root = Arry[root];
	}
	//路径压缩
	while(num != root){
		temp = Arry[num];//暂存结果 
		Arry[num] = root;//用于判断上升一级后是否到达了顶端 
		num = temp;//相当于不断地给num升职加薪 
	} 
	return num;
}
void Union(int a,int b)
{
	int aRoot = Find(a);
	int bRoot = Find(b);
	if(aRoot != bRoot) 
		Arry[aRoot] = bRoot;
}
int main()
{
	int n,k,h,ans = 0;
	cin>>n;
	Arry.resize(n+1);
	isRoot.resize(n+1);
	for(int i = 1; i <= n; i++){
		Arry[i] = i;
	}
	for(int i = 1; i <= n; i++){//人的编号 
		scanf("%d:", &k);
		for(int j = 0; j < k; j++){
			scanf("%d", &h);
			if(hobby[h] == 0){
				hobby[h] = i;
			}
			Union(i, hobby[h]);
		}
	}
	for(int i = 1; i <= n; i++){
		//isRoot[i]=0,则是非根节点;否则,是根节点,且isRoot[i]中保存的是当前圈子中的人数
		isRoot[Find(i)]++; 
	}
	for(int i = 1; i <= n; i++){
		if(isRoot[i] != 0) ans++;
	}
	sort(isRoot.begin(), isRoot.end(), cmp);
	cout<<ans<<endl;
	for(int i = 0; i < ans-1; i++){
		cout<<isRoot[i]<<" ";
	} 
	cout<<isRoot[ans-1];
	return 0;
}
  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值