PAT甲级-1064-Complete Binary Search Tree(二叉搜索树+完全二叉树+中序转层序)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
  • The right subtree of a node contains only nodes with keys greater than the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

思路:

1、根据中序遍历序列以及以下公式(左子树结点数)求出根结点root下标
2、将求出的根节点root加入到层序遍历序列的vector中
3、递归求左右子树根结点,并加入层序遍历序列的vector中(即重复步骤1,2)
注意:n随着子树的递归减小在不断变小!
在这里插入图片描述
注意:由于是左子树,所以结点数要减半,即k-1!

代码如下

#include<iostream>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
vector<int>in,level;
void levelOrder(int start,int end,int index)
{
	if(start > end) return;
	int n = end-start+1;
	int k = log(n+1)/log(2);
	int leave = n-(pow(2,k)-1);
	int root = start+(pow(2,k-1)-1)+min((int)pow(2,k-1),leave);
	level[index] = in[root];
	levelOrder(start,root-1,index*2+1);
	levelOrder(root+1,end,index*2+2);
}
int main()
{
	int n;
	cin>>n;
	in.resize(n);
	level.resize(n);
	for(int i = 0; i < n; i++){
		scanf("%d", &in[i]);
	}
	sort(in.begin(), in.end());
	levelOrder(0,n-1,0);
	for(int i = 0; i < n-1; i++){
		cout<<level[i]<<" ";
	}
	cout<<level[n-1];
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值