2019ICPC 沈阳重现 L-Flowers(二分)

7-7 L-Flowers
Recently Jack becomes much more romantic. He would like to prepare several bunches of flowers.

Each bunch of flowers must have exactly M flowers. As Jack does not want to be boring, he hopes that flowers in the same bunch are all different species. Now there are N species of flowers in the flower shop, and the number of the i-th species of flower is a​i. Now Jack would like to know how many bunches of flowers he can prepare at most.

(Flowers are used to propose.)
Sample Input
1
5 3
1 1 1 2 1

Sample Output
2
思路:二分答案,看一下共x朵花,每朵花m个不同的花组成能不能满足就行了。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=3e5+1; 
int T,n;
ll k,a[maxn];
bool check(ll x)
{
	ll sum=0;
	for(int i=1;i<=n;++i) sum+=min(a[i],x);
	return sum>=x*k;
}
int main()
{
	scanf("%d",&T);
	while(T--)
	{
		ll sum=0;
		scanf("%d %lld",&n,&k);
		for(int i=1;i<=n;++i) scanf("%lld",&a[i]),sum+=a[i]; 
		ll l=0,r=sum,mid;
		while(l<=r)
		{
			mid=(l+r)>>1;
			if(check(mid)) l=mid+1;
			else r=mid-1;
		}
		printf("%lld\n",r);
	} 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值