hdu3986 Harry Potter and the Final Battle(spfa)

题目链接
Problem Description
The final battle is coming. Now Harry Potter is located at city 1, and Voldemort is located at city n. To make the world peace as soon as possible, Of course, Harry Potter will choose the shortest road between city 1 and city n. But unfortunately, Voldemort is so powerful that he can choose to destroy any one of the existing roads as he wish, but he can only destroy one. Now given the roads between cities, you are to give the shortest time that Harry Potter can reach city n and begin the battle in the worst case.

Input
First line, case number t (t<=20).
Then for each case: an integer n (2<=n<=1000) means the number of city in the magical world, the cities are numbered from 1 to n. Then an integer m means the roads in the magical world, m (0< m <=50000). Following m lines, each line with three integer u, v, w (u != v,1 <=u, v<=n, 1<=w <1000), separated by a single space. It means there is a bidirectional road between u and v with the cost of time w. There may be multiple roads between two cities.

Output
Each case per line: the shortest time to reach city n in the worst case. If it is impossible to reach city n in the worst case, output “-1”.

Sample Input
3
4
4
1 2 5
2 4 10
1 3 3
3 4 8
3
2
1 2 5
2 3 10
2
2
1 2 1
1 2 2

Sample Output
15
-1
2

Author
tender@WHU

Source
2011 Multi-University Training Contest 15 - Host by WHU
思路:由于数据范围还行,考虑枚举最短路上的每条边,把这条边删除后跑一遍spfa。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 5e4+5;
const int inf=1e9+100;
int d[maxn];
struct cxk{
    int v,w,id;
};
int flag=1,p[maxn],pre[maxn],num[maxn];
vector<cxk>g[maxn];
bool vis[maxn];
void spfa(int x)
{
    memset(vis,false,sizeof(vis));
    for(int i=0;i<maxn;++i) d[i]=inf;
    d[x]=0;
    queue<int>q;
    q.push(x);
    vis[x]=true;
    while(!q.empty())
    {
        int top=q.front();
        q.pop();
        vis[top]=false;
        for(auto v:g[top])
        {
            if(p[v.id]) continue;
            if(d[top]+v.w<d[v.v])
            {
                d[v.v]=d[top]+v.w;
                if(flag)
                {
                    pre[v.v]=top;num[v.v]=v.id;
                }
                if(!vis[v.v]) q.push(v.v),vis[v.v]=true;
            }
        }
    }
}
int main()
{
    int T,n,u,v,w,m;
    scanf("%d",&T);
    while(T--)
    {
        memset(p,0,sizeof(p));
        memset(pre,0,sizeof(pre));
        memset(num,0,sizeof(num));
        flag=1;
        scanf("%d %d",&n,&m);
        for(int i=0;i<=n;++i) g[i].clear(); 
        for(int i=1;i<=m;++i)
        {
            scanf("%d %d %d",&u,&v,&w);
            u--,v--;
            g[u].push_back({v,w,i});
            g[v].push_back({u,w,i});
        }
        spfa(0);
        if(d[n-1]==inf) {
            printf("-1\n");continue;
        }
        flag=0;
        int ans=0,flag1=0;
        for(int i=n-1;i!=0;i=pre[i])
        {
            p[num[i]]=1;
            spfa(0);
            p[num[i]]=0;
            if(d[n-1]==inf) {
            flag1=1;printf("-1\n");break;
        }
        ans=max(ans,d[n-1]);
        }
        if(flag1) continue;
        if(ans==inf) puts("-1");
        else printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值