HDU4632 Palindrome subsequence(区间DP)

题目链接
Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, …, Sxk> and Y = <Sy1, Sy2, …, Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.

Sample Input
4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems

Sample Output
Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960

Source
2013 Multi-University Training Contest 4
题意:给定一个字符串,求这个字符串中包含多少回文子串(子串可以不连续)

#include<bits/stdc++.h> 
using namespace std;
const int maxn = 1005;
typedef long long ll;
const int mod=10007;
char s[maxn];
ll dp[maxn][maxn];
int main()
{
    int T;
    scanf("%d",&T);
    for(int m=1;m<=T;++m)
    {
        scanf("%s",s+1);
        int n=strlen(s+1);
        for(int i=1;i<=n;++i)
        {
            for(int j=1;j<=n;++j) dp[i][j]=0;
            dp[i][i]=1;
        }
        for(int len=1;len<=n;++len)
        {
            for(int l=1;l+len-1<=n;++l)
            {
                int r=l+len-1;
                dp[l][r]=(dp[l+1][r]+dp[l][r-1]-dp[l+1][r-1]+mod)%mod;
                if(s[l]==s[r]) dp[l][r]=(dp[l][r]+dp[l+1][r-1]+1)%mod;
            }
        }
        printf("Case %d: %lld\n",m,dp[1][n]);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值