POJ2955 Brackets(区间DP)

题目链接
We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6

#include<iostream>
#include<cstring>
using namespace std;
const int maxn = 105;
typedef long long ll;
const ll inf=1e18;
ll dp[maxn][maxn];
char s[maxn];
int main()
{
	while(scanf("%s",s+1)!=EOF)
	{
		if(s[1]=='e') break;
		int n=strlen(s+1);
		memset(dp,0,sizeof(dp));
		for(int len=2;len<=n;++len)
		{
			for(int l=1;l+len-1<=n;++l)
			{
				int r=l+len-1;
				if((s[l]=='('&&s[r]==')')||(s[l]=='[')&&s[r]==']') dp[l][r]=dp[l+1][r-1]+2;
				for(int k=l;k<r;++k)
				dp[l][r]=max(dp[l][r],dp[l][k]+dp[k+1][r]);
			}
		}
		printf("%lld\n",dp[1][n]);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值