【HDU 4800 】【Josephina and RPG】

题目:

A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.

Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.

The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team get victory only if they beat all the AI teams.

Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?

Input

There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix Twhose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains Nintegers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.

Output

For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.

Sample Input

4
0.50 0.50 0.20 0.30
0.50 0.50 0.90 0.40
0.80 0.10 0.50 0.60
0.70 0.60 0.40 0.50
3
0 1 2

Sample Output

0.378000

题意:会给我们一个数字m,会有C(3,m)支队伍,交代我们每支队伍和其他队伍的胜率,(i,j)和(j,i)的胜率和为1 ,之后交代n支队伍,问我们打败他们的最大胜率是多少(注,特殊操作,在打败这支队伍之后,胜的可以选择,自己代替输掉的队伍,拥有他们的比赛胜率,当然也可以选择不交换)

解题思路:每次打败一支队伍后,都要选择是不是要替换,所以dp分两支进行。状压dp,最后循环寻求最大解。

ac代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#define maxn 10008
#include<iostream>
int a[maxn];
double p[350][350];
double dp[maxn][350];
int n,m;

int main()
{
	while(scanf("%d",&m)!=EOF)
	{
		m=m*(m-1)*(m-2);
		m/=6;
		for(int i=0;i<m;i++)
			for(int j=0;j<m;j++)
				scanf("%lf",&p[i][j]);
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		memset(dp,0,sizeof(dp));
		for(int i=0;i<=m;i++)
			dp[0][i]=1.0;
		for(int i=1;i<=n;i++)
			for(int j=0;j<m;j++)
			{
				if(dp[i][j]>dp[i-1][j]*p[j][a[i]])
					dp[i][j]=dp[i][j];//换 
				else
					dp[i][j]=dp[i-1][j]*p[j][a[i]];
				if(dp[i][a[i]]>dp[i-1][j]*p[j][a[i]])
					dp[i][a[i]]=dp[i][a[i]];//不换 
				else
					dp[i][a[i]]=dp[i-1][j]*p[j][a[i]];
			}
		double ans=0;
		for(int i=0;i<m;i++)
		{
			if(ans<dp[n][i])
				ans=dp[n][i];
		}
		//	ans=max(ans,dp[n][i]);
		printf("%.7lf\n",ans); 
	} 
	return 0;
}

解题思路:dp分

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值