ZOJ 3735 Josephina and RPG (概率dp)

Josephina and RPG
Time Limit: 2 Seconds Memory Limit: 65536 KB Special Judge
A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.

Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the “Challenge Game” part.

The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team get victory only if they beat all the AI teams.

Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?

Input
There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.

Output
For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.

Sample Input
4
0.50 0.50 0.20 0.30
0.50 0.50 0.90 0.40
0.80 0.10 0.50 0.60
0.70 0.60 0.40 0.50
3
0 1 2
Sample Output
0.378000

题意

你有 C m 3 C_{m}^3 Cm3支队伍,他们相互之间比赛的胜率,现在给你n场比赛的顺序,一开始你可以任意选择一支队伍作为你的队伍,然后去和第一支队伍比赛,赢了以后你可以考虑把队伍保留或者换成这支队伍,现在问你n场比赛都获胜的最大胜率是有多大

思路

我们考虑二维的概率dp, d p [ i ] [ j ] dp[i][j] dp[i][j],其中i代表已经进行了i场比赛,j表示在已经进行了i场然后接下去用j打赢全部比赛的概率。那么就会有dp转移方程了
d p [ i ] [ j ] = p [ j ] [ a [ i ] ] ∗ m a x ( d p [ i + 1 ] [ j ] , d p [ i + 1 ] [ a [ i ] ] ) dp[i][j]=p[j][a[i]]*max(dp[i+1][j],dp[i+1][a[i]]) dp[i][j]=p[j][a[i]]max(dp[i+1][j],dp[i+1][a[i]])
考虑下一场比赛是换成a[i]还是保持j哪一个概率更优就有这个式子了

#include <bits/stdc++.h>
using namespace std;
const int N = 10005;
double p[200][200];
double dp[N][200];
int a[N];
int main()
{
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        int r=m*(m-1)*(m-2)/6;
    for(int i=0;i<r;i++)
        for(int j=0;j<r;j++)
        scanf("%lf",&p[i][j]);
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
    for(int i=0;i<n;i++)
        for(int j=0;j<r;j++)
        dp[i][j]=0;
    for(int j=0;j<r;j++)
        dp[n-1][j]=p[j][a[n-1]];
    for(int i=n-2;i>=0;i--)
        for(int j=0;j<r;j++)
    {
        dp[i][j]=p[j][a[i]]*max(dp[i+1][a[i]],dp[i+1][j]);
    }
    double ans=0;
    for(int i=0;i<r;i++)
        ans=max(ans,dp[0][i]);
    printf("%.6lf\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值