【POJ - 2823 】【Sliding Window】

题目:

An array of size n ≤ 10 6 is given to you. There is a sliding window of size kwhich is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

 题意:给我们一个数组,我们有一块挡板,然后在挡板中有空,咱们能够通过空看到一些(k个)数字,然后问我们这个空 从数组前端走到尾端,每次能看到的最小值最大值需要记录一下,最后两行输出。

解题思路:刚上来打算使用单调栈求解,后来发现不能实现它所要求的,然后看了一下题解后,发现居然是手写单调队列。。。

ac代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<stack>
#include<queue>
#define maxn 1000100
using namespace std;
int n,k;
int num[maxn],loc[maxn],que[maxn];
int ans[maxn];
void get_min()
{
	int i;
	int head=1;
	int tail=0;
	for(i=0;i<k-1;i++)
	{
		while(head<=tail&&que[tail]>=num[i])
			--tail;
		que[++tail]=num[i];
		loc[tail]=i;
	}
	for(;i<n;i++)
	{
		while(head<=tail&&que[tail]>=num[i])
			--tail;
		que[++tail]=num[i];
		loc[tail]=i;
		while(loc[head]<i-k+1)
			head++;
		ans[i-k+1]=que[head];
	}
}
void get_max()
{
	int i;
	int head=1;
	int tail=0;
	for(i=0;i<k-1;i++)
	{
		while(head<=tail&&que[tail]<=num[i])
			--tail;
		que[++tail]=num[i];
		loc[tail]=i;
	}
	for(;i<n;i++)
	{
		while(head<=tail&&que[tail]<=num[i])
			--tail;
		que[++tail]=num[i];
		loc[tail]=i;
		while(loc[head]<i-k+1)
			head++;
		ans[i-k+1]=que[head];
	}
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		for(int i=0;i<n;i++)	
			scanf("%d",&num[i]);
		get_min();
		for(int i=0;i<n-k;i++)
			printf("%d ",ans[i]);
		printf("%d\n",ans[n-k]);
		memset(ans,0,sizeof(ans));
		get_max();
		for(int i=0;i<n-k;i++)
			printf("%d ",ans[i]);
		printf("%d\n",ans[n-k]);
		memset(ans,0,sizeof(ans));
	}	
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值