2019/11/04算法课在线练习nenuoj
Problem Description
有一个一元三次方程ax3+bx2+cx+d=0,给出所有的系数,并规定该方程存在3个不同的实根(根范围为-100~100),且根与根之差的绝对值>=1。要求从小到大一次在同一行输出这3个根,并精确到小数点后两位。
Input
包含4个实数,a,b,c,d,各实数之间用空格隔开。
Output
从小到大的3个实根。各跟之间用空格隔开。
Sample Input
1 -5 -4 20
Sample Output
-2.00 2.00 5.00
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
double a,b,c,d;
double k;
int n;
int main()
{
cin>>a>>b>>c>>d;
for(k=-100.00;k<=100.00;k+=0.01)
{
if(a*k*k*k+b*k*k+c*k+d<0.00000001&&a*k*k*k+b*k*k+c*k+d>-0.00000001
n++;
printf("%.2lf",k);
if(n!=3)
cout<<' ';
}
}
return 0;
}