poj2488

A Knight’s Journey

POJ 2488

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 51143Accepted: 17327
Description
Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

—————————————————分割线

主要就是一匹马在国际象棋的棋盘上乱跳 判断跳完否 当然有许多细节
其实好多博客上都有解释 去看吧

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int time=0;
int n;
int startx,starty;
int next[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};//方向变量 
int book[30][30];
struct node{
    char x;                                                              //保存路径 
    char y;
}path[30];
bool final=false;

void DFS(int x,int y,int step){

    path[step].y=y+'A'-1; //t    //转换字符 
    path[step].x=x+'0';
    if(step==startx*starty){          //是否都已经走过 
            final=true;
            return;
        }
    for(int i=0;i<=7;i++){              //DFS主体
        int tx=x+next[i][0];
        int ty=y+next[i][1];
        if(tx>0 && tx<=startx && ty>0 && ty<=starty && !book[tx][ty] && !final){

                book[tx][ty]=1;
                DFS(tx,ty,step+1);
                book[tx][ty]=0;

        }
    }
    return;
}

int main(){

    scanf("%d",&n);
    while(n){

        ++time;
        scanf("%d%d",&startx,&starty);
        memset(book,0,sizeof(book));
        final=false;
        book[1][1]=1;   //起点已走过 
        DFS(1,1,1);
        printf("Scenario #%d:\n",time);         //次数
        if(final){                              //全部走完
            for(int i=1;i<=startx*starty;i++){
                printf("%c%c",path[i].y,path[i].x);   //输出路径
            }
            printf("\n");
        }
        else {                                                                
            printf("impossible");     //并没有都走完 
            printf("\n");
        }
        if(time!=n){           //poj上的输出真是别具心裁 要注意
            printf("\n");
        }
        n--;
}
    return 0;
}
  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值