PAT 1009 Product of Polynomials (25分)

题目:
This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

解题思路:
这道题可以用两个结构体数组保存输入的多项式,然后进行指数相加,系数相乘的运算,并合并同类项后保存在一个数组里,相加后的指数作为数组下标,系数作为对应下标的值。
需要注意的是:
1、系数为0的情况不输出;
2、输出格式要注意,系数保留小数点后一位;
3、运算后保存的数组需是所输入多项式的两倍的内存空间(这点是我太粗心没考虑到,导致后面两个测试点过不去。。。)

代码如下:

#include<stdio.h>
#include<iomanip>
#include<iostream>
using namespace std;

typedef struct poly{
	int exp;
	double cof;
};
struct poly a[1001], b[1001];
double N[2002];

int main() {	
	int m, count = 0;
	int K1, K2, K3 = 0;
	cin >> K1;
	for (int i = 0; i < K1; i++) {
		cin >> a[i].exp >> a[i].cof;
	}
	cin >> K2;
	for (int i = 0; i < K2; i++) {
		cin >> b[i].exp >> b[i].cof;
	}
	for(int i=0;i<K1;i++)
		for (int j = 0; j < K2; j++) {
			N[a[i].exp + b[j].exp] += a[i].cof * b[j].cof;
		}

	for (int i = 0; i < 2002; i++) {
		if (N[i] != 0) //除去系数为0的情况
			count++;
	}
	cout << count;	
	for (int i = 2002; i >= 0; i--)
		if(N[i]!=0)
			cout << " " << i << " " << setiosflags(ios::fixed) << setprecision(1) << N[i];
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值