PAT甲级——Product of Polynomials

his time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

思路: 

         题目要求的是多项式的乘积,首先开两个数组分别存放两个多项式的信息,数组下标为指数,对应的数组元素为系数,比如a[5]=3.4,表示指数为5的项,系数为3.4。然后开一个ans数组,进行双重循环,将上面两个数组相乘的信息纪律下来:

ans[i+j] += p1[i] * p2[j]。这里有几个要注意的地方,首先数组要开float类型的,因为系数可以是小数。数组的大小要开到2000+,因为指数相加的结果最大是1000+1000=2000,小了就会出现越界的错误。

代码:

#include <iostream>
using namespace std;
const int maxn = 2010;
float p1[maxn] = { 0.0 }, p2[maxn] = { 0.0 },ans[maxn] = { 0.0 };


int main()
{
	int n, m,ex;
	float co;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d %f", &ex, &co);
		p1[ex] = co;
	}
	//getchar();
	scanf("%d", &m);
	for (int i = 0; i < m; i++)
	{
		scanf("%d %f", &ex, &co);
		p2[ex] = co;
	}
	int count = 0;
	for (int i = 0; i <=1000; i++)
	{
		for (int j = 0; j <=1000; j++)
		{
			ans[i+j] += p1[i] * p2[j];
			
		}
	}
	for (int i = 0; i < maxn; i++)
	{
		if (ans[i] != 0) count++;
	}
	printf("%d", count);
	for (int i = maxn; i >= 0; i--)
	{
		if (ans[i] != 0)
		{
			printf(" %d %.1f", i, ans[i]);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值