PAT 1013 Battle Over Cities (25分)

题目:

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

解题思路:
本题相当于一个找连通分量的问题。一个连通图中去掉一个结点(相当于题目中的某个城市被占领)之后看还有多少个连通分量,连通分量个数 减1 就是至少所需的边数将各个连通分量连接起来,使成为一个连通图。
用深度优先遍历DFS来找出全部的连通分量。
这里记录下我遇到的一个问题:就是不能用cin,否则会出现运行超时的错误,因为cin是输入流,对输入特别大的数组来说花费时间太长。

代码如下:

#include<stdio.h>
#include<cstring>
#include<iostream>
using namespace std;
int N, M, K;
int G[1001][1001];
int visited[1001];

void DFS(int s) {
	visited[s] = 1;
	for (int v = 1; v <= N; v++) {
		if (!visited[v] && G[s][v]) {
			DFS(v);
		}
	}
}

int main() {
	int n, m, x;
	//cin >> N >> M >> K;
	scanf("%d%d%d", &N, &M, &K);
	for (int i = 0; i < M; i++) {
		//cin >> n >> m;
		scanf("%d%d", &n, &m);
		G[n][m] = 1;
		G[m][n] = 1;
	}
	for (int i = 0; i < K; i++) {
		//cin >> x;
		scanf("%d", &x);
		int cnt = 0;
		memset(visited, 0, sizeof(visited));
		visited[x] = 1;
		for (int j = 1; j <= N; j++) {
			if (!visited[j]) {
				DFS(j);
				cnt++;
			}
		}
		cout << cnt - 1 << endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值