Hashing - Average Search Time

                               7-2 Hashing - Average Search Time (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

思路:如果tsize不是素数,先找到最近的素数赋值给tsize,开辟一个长度为tsize的vector数组,插入时如果探测到当前位置的值为0,就将元素的值插入到此位置,如果找了tsize次仍然没有找到就输出cannot be inserted。查找之前设置查找次数sum=0,对于每一个查找的元素每次查找时如果当前位置的值等于该元素的值,或者当前位置的值为0,停止继续查找。最后将sum/m就是答案

#include <iostream>
#include<bits/stdc++.h>
using namespace std;
bool isprime(int m)
{
    if(m==1)
        return false;
    int i;
    for(i=2;i<sqrt(m);i++)
        if(m%i==0)
            break;
    if(i>sqrt(m))
        return true;
    return false;
}
int main()
{
    int tsize,n,m,e;
    cin>>tsize>>n>>m;
    while(!isprime(tsize))
    {
        tsize++;
    }
    vector<int> v(tsize);
    for(int i=0;i<n;i++)
    {
        cin>>e;
        int f=0;
        for(int j=0;j<=tsize;j++)
            if(v[(e+j*j)%tsize]==0)
            {
                v[(e+j*j)%tsize]=e;
                f=1;
                break;
            }
        if(f==0)
            cout<<e<<" cannot be inserted."<<endl;
    }
    int sum=0;
    for(int i=0;i<m;i++)
    {
        cin>>e;
        for(int j=0;j<=tsize;j++)
        {
            sum++;
            if(v[(e+j*j)%tsize]==e||v[(e+j*j)%tsize]==0)
                break;
        }
    }
    printf("%.1lf\n",sum*1.0/m);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值