1107 Social Clusters

                                 1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

 

#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int n,p[1001],num,e;
int findp(int a)
{
    if(a!=p[a])
        p[a]=findp(p[a]);
    return p[a];
}
void join(int a,int b)
{
    a=findp(a);
    b=findp(b);
    p[a]=b;
}
map<int,vector<int> > Map;
int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
        p[i]=i;
    for(int i=1;i<=n;i++)
    {
        scanf("%d:",&num);
        for(int j=0;j<num;j++)
        {
            cin>>e;
            Map[e].push_back(i);
        }
    }
    for(map<int ,vector<int> >::iterator it=Map.begin();it!=Map.end();it++)
        if(it->second.size()>=2)
    {
        int fir=it->second[0];
        for(int j=1;j<it->second.size();j++)
            join(fir,it->second[j]);
    }
    set<int> ans;
    map<int,int> Map2;
    for(int i=1;i<=n;i++)
    {
        ans.insert(findp(i));
        Map2[findp(i)]++;
    }
    cout<<ans.size()<<endl;
    vector<int> ans2;
    for(map<int,int>::iterator it=Map2.begin();it!=Map2.end();it++)
        ans2.push_back(it->second);
    sort(ans2.begin(),ans2.end());
    reverse(ans2.begin(),ans2.end());
    cout<<ans2[0];
    for(int i=1;i<ans2.size();i++)
        cout<<" "<<ans2[i];
    cout<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值