POJ - 1013结题报告

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 52815 Accepted: 16509

Description
Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input
The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A–L. Information on a weighing will be given by two strings of letters and then one of the words up'',down’’, or ``even’’. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output
For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even

Sample Output

K is the counterfeit coin and it is light.

Source
East Central North America 1998

题目大意:给你12个银元和3次称量的结果,要你找出与众不同的那一枚。

分析:初看感觉很难,因为逻辑分析对人来说很容易,但用电脑来实现却是有些困难的。感觉不知道从何处下手。下面是大佬的代码,里面通过每次称量标记怀疑银元,最后找出嫌疑最大的那个,感觉还是很巧妙的。

代码:

#include<iostream>
#include<cmath>
using namespace std;

int main()
{
	int n;
	char left[3][6],right[3][6],status[3][6];//记录每次称量的银元
	cin>>n;
	while(n--)
	{
		int time['L'+1]={0};//标记怀疑程度
		bool zero['L'+1]={false};//用来彻底免除嫌疑
		for(int i=0;i<3;i++)
			cin>>left[i]>>right[i]>>status[i];
		for(int i=0;i<3;i++)
		{
			switch(status[i][0])//通过switch完成分类
			{
				case 'u':
					{
						for(int j=0;left[i][j];j++)
						{
							time[left[i][j]]++;
							time[right[i][j]]--;
						}
						break;
					}
				case 'd':
					{
						for(int j=0;left[i][j];j++)
						{
							time[left[i][j]]--;
							time[right[i][j]]++;
						}
						break;
					}
				case 'e':
					{
						for(int j=0;left[i][j];j++)
						{
							zero[left[i][j]]=true;
							zero[right[i][j]]=true;
						}
						break;
					}
			}
		}
		int max=-1;
		char alpha;
		for(int i='A';i<='L';i++)
		{
			if(zero[i])
				continue;
			if(max<=abs(time[i]*1.0))//如果嫌疑大
			{
				max=abs(time[i]*1.0);
				alpha=i;//记录最大嫌疑银元
			}
		}
		cout<<alpha<<" is the counterfeit coin and it is ";
		if(time[alpha]>0)//通过正负判断轻重
			cout<<"heavy."<<endl;
		else
			cout<<"light."<<endl;
	}
	return 0;
}

后记:本来是一道难度不大的题(还有一小点语言知识),却困了我很久,好在这种题特征很明显,完成一道后其他的应该也可以用类似的方法完成。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值