POJ - 1384解题报告---完全背包

Piggy-Bank
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14126 Accepted: 6747

Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

Source
Central Europe 1999

题意:求出储物罐满时的最小金额,如果不存在,则输出不可能。

分析:很普通的完全背包问题,通用方法就可以解决。
同样也可以使用滚动数组降低空间复杂度。
例如:dp[i][j]=x意味在使用前i种硬币达到j重量时,总金额数最小为x。列出状态转移方程:
dp[i][j]=min{dp[i][j],dp[i][j-w[i]]+val[i]}
但是最终只需要dp[n][m],而且dp[i][j]只与dp[i-1][j]有关。故可使用dp[m]不断更新取而代之。

代码:

#include<iostream>
#define maxn 50005
#define inf 1e9
using namespace std;

int t,m;//直接使用m储存重量,便于分析
int n,w[maxn],val[maxn];//w数组储存硬币重量,val数组储存硬币价值
int dp[10005];

void solve()
{
	for(int i=1;i<=n;i++)
		for(int j=w[i];j<=m;j++)//01背包与完全背包的主要区别
			dp[j]=min(dp[j],dp[j-w[i]]+val[i]);
}

int main()
{
	cin>>t;
	while(t--)
	{
		int m1,m2;
		cin>>m1>>m2;
		m=m2-m1;
		for(int i=0;i<=m;i++)
			dp[i]=inf;//将初值设为无穷大,因为题目要求求的是最小值
		dp[0]=0;
		cin>>n;
		for(int i=1;i<=n;i++)
			cin>>val[i]>>w[i];
		solve();
		if(dp[m]==inf)
			cout<<"This is impossible."<<endl;
		else
			cout<<"The minimum amount of money in the piggy-bank is "<<dp[m]<<"."<<endl;
	}
	return 0;
}

后记:完全背包作为01背包的变种,与其在很多地方有相似之处,应该着重区分。动态规划问题需要很高的熟练度才能很好的解决,以后要加强练习。

附:
一篇更好的分析:https://blog.csdn.net/u013480600/article/details/40453509
大神的《背包九讲》:https://www.cnblogs.com/jbelial/articles/2116074.html

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值