POJ - 1068解题报告——模拟

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28972 Accepted: 17067

Description
Let S = s1 s2…s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2…pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2…wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S		(((()()())))

P-sequence	    4 5 6666

W-sequence	    1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source
Tehran 2001

题意:一个用(和)组成的字符串s可以用p,w两种数组表示,给你一个p数组,求其对应的w数组。其中p[i]=n指的是第i个)前有n个(,w[i]=n是指第i个)组成的()包含了n个()。

分析:注意题目说的是a well-formed string,意思是每个前后括号都是一一对应的,不会出现)前没有(的情况。解答过程就是先根据p数组求出s,再用s求w数组。

代码:

#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	int t;
	cin>>t;
	bool vis[45];//用vis数组判断(和)的对应情况
	while(t--)
	{
		memset(vis,0,sizeof(vis));
		int p[25]={0},w[25]={0};
		string s;
		int n;
		cin>>n;
		for(int i=1;i<=n;i++)
			cin>>p[i];
		p[0]=0;
		int k=1;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=p[i]-p[i-1];j++)//p[i]-p[i-1]可表示两个)之间的(数
			{
				s[k++]='(';
			}
			s[k++]=')';
		}
		/*for(int i=1;i<=2*n;i++)
			cout<<s[i]<<endl;查看s字符串是否正确*/
		int cnt;
		k=1;
		for(int i=1;i<=2*n;i++)
		{
			cnt=0;
			if(s[i]==')')
			{
				for(int j=i-1;j>=1;j--)
				{
					if(s[j]==')')//由于每一个)都有前置(配对,可以用)数反映()数
						cnt++;
					if(s[j]=='('&&!vis[j])//发现第一个没有配对的(
					{
						vis[j]=1;//配对
						break;
					}
				}
				w[k++]=++cnt;//cnt记录的是()之中的()数,还要加一个它本身
			}
		}
		for(int i=1;i<=n;i++)//格式控制(不过不控也能过emmm)
		{
			if(i==1)
				cout<<w[i];
			else
				cout<<" "<<w[i];
		}
		cout<<endl;
	}
	return 0;
}

后记:做题的时候没有注意到well-formed,想了很久都无果,有点气。这道题算w时是先从左向右枚举s,发现)后就从右向左寻找第一个未配对的(,该(一定就是配对的(。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值