Red and Black

Red and Black

 HDU - 1312 

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题目大意:一个人站在符号位“@”的瓦片上,有红色瓦片“#”和黑色瓦片“.”,他只能走黑色瓦片不能走红色瓦片,问走的最多的黑色瓦片的个数。

题目很好理解,一看就是一个深搜DFS,不过用BFS也可以做,下面贴出两种代码:

DFS

#include<bits/stdc++.h>
using namespace std;
const int MAXN=30;
int n,m,sum;
char str[MAXN][MAXN];
int vis[MAXN][MAXN];
int d[4][2]={1,0,-1,0,0,1,0,-1};

void DFS(int x,int y){
    if(x<0||x>=n||y<0||y>=m||vis[x][y]==1||str[x][y]=='#')
    	return;
  	else{
	  	sum++;
	  	int dx,dy;
  		for(int i=0;i<4;i++){
			vis[x][y]=1;
			dx = x + d[i][0];
			dy = y + d[i][1];
			DFS(dx,dy);
    	}
	}  
}

int main(){
	while(~scanf("%d %d",&m,&n)&&(m||n)){
    	memset(str,0,sizeof(str));
    	memset(vis,0,sizeof(vis));
    	sum=0;
    	for(int i=0;i<n;i++){
    		scanf("%s",&str[i]);
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(str[i][j]=='@') {
					DFS(i,j);
					break;
				}
			}	
		}
		printf("%d\n",sum);
	}
    
    return 0;
}

BFS

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <queue>
using namespace std;
const int MAXN=30;

int n,m,sum;
char str[MAXN][MAXN];
bool vis[MAXN][MAXN];
int d[4][2]={1,0,-1,0,0,1,0,-1};

bool check(int x,int y){
    if(str[x][y]=='#'||x<0||x>=n||y<0||y>=m)
        return false;
    else return true;
}
struct node{
	int x,y;
}e1,e2;
queue<node> que;

void BFS(int x,int y){
	e1.x=x,e1.y=y;
	que.push(e1);
	vis[x][y]=true;
	while(!que.empty()){
		sum++;
		e1=que.front();
		que.pop();
		for(int i=0;i<4;i++){
			e2.x = e1.x + d[i][0];
			e2.y = e1.y + d[i][1];
			if(check(e2.x,e2.y)&&!vis[e2.x][e2.y]) {
				que.push(e2);
				vis[e2.x][e2.y]=1;
			}
		}
	}
}
int main(){
	while(~scanf("%d %d",&m,&n)&&(m||n)){
		memset(str,0,sizeof(str));
		memset(vis,0,sizeof(vis));
		sum=0;
		while(!que.empty())
			que.pop();
		for(int i=0;i<n;i++){
			scanf("%s",&str[i]);
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(str[i][j]=='@') {
					BFS(i,j);
					break;
				}
			}	
		}
		printf("%d\n",sum);
	}
    return 0;
}

	

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值