题目:
Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.
Input
Input starts with an integer T (≤ 525), denoting the number of test cases.
Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.
Output
For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.
Sample Input
6
101 101
0 67
-101 101
7678123668327637674887634 101
11010000000000000000 256
-202202202202000202202202 -101
Sample Output
Case 1: divisible
Case 2: divisible
Case 3: divisible
Case 4: not divisible
Case 5: divisible
Case 6: divisible
题意:给你两个大数a和b,问你a是否能被b整除,能的话输出"divisible",不能的话输出"not divisible".
就是一个大数取模的模板题,代码如下:
#include<iostream>
#include <stdio.h>
#include<string.h>
using namespace std;
int main(){
char a[300];
long long t,n,l,ans,k;
cin>>t;
for(int j=1;j<=t;j++){
scanf("%s",a);
scanf("%lld",&n);
l=strlen(a);
ans=0;
k=0;
for(int i=0;i<l;i++){
if(a[i]=='-')
continue;
ans=(ans*10 + (a[i]-'0'))%n;
if(ans==0) {
k=1;
break;
}
}
if(k==1){
cout<<"Case"<<" "<<j<<":"<<" "<<"divisible"<<endl;
}
else cout<<"Case"<<" "<<j<<":"<<" "<<"not divisible"<<endl;
}
return 0;
}