Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center
of gravity of the triangle?
Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.
Output
For each case, print the coordinate, accurate up to 1 decimal places.
Sample Input
2
1.0 2.0 3.0 4.0 5.0 2.0
1.0 1.0 4.0 1.0 1.0 5.0
0
Sample Output
3.0 2.7
2.0 2.3
分析:就是求三角形的重心,直接利用三角形的重心坐标公式即可,水题。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm >
using namespace std;
struct pt{
double x;
double y;
}a,b,c,d;
int main(){
int t,n;
while(cin>>t&&t!=0){
while(t--){
cin>>a.x>>a.y>>b.x>>b.y>>c.x>>c.y;
d.x=(a.x+b.x+c.x)/3.0;
d.y=(a.y+b.y+c.y)/3.0;
printf("%.1lf %.1lf\n",d.x,d.y);
}
}
return 0;
}