[kuangbin带你飞]专题2 搜索进阶 A - Eight

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 

 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x


where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 

 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->


The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement. 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases. 

Sample Input

2  3  4  1  5  x  7  6  8

Sample Output

ullddrurdllurdruldr

分析:运用逆向思维,一个状态能到终点状态,那么从终点也一定能到达该状态,所以我们需要从终点开始,将能够到达的位置及步骤存起来。

这里9个数,有9!中不同的状态,我们按照9个数的全排列大小来存每种状态,这里需要用到康托展开。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
#include<string>
using namespace std;
const int M=5e5+10;

int fac[]={1,1,2,6,24,120,720,5040,40320,362880};
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};

struct node{
	int s[10];  //该状态的数组形态 
	int x;		//该状态x的位置 
	int vis;	//根据康托展开后该状态在全排列下的位置 
	string sr;  //从这个状态到最终状态该怎么走 
};

int vis[M],ss[9];
string str[M];		//记录每个状态到最终状态的步骤 
char index[5]="lrud";

int cantor(int a[]){   //康托展开式,返回的是该状态在全排列中的位置 
	int res=0;
	for(int i=0;i<9;i++){
		int count=0;
		for(int j=i+1;j<9;j++)
			if(a[i]>a[j]) count++;
		res+=count*fac[9-i-1];
	}
	return res;
}
void bfs(){
	memset(vis,0,sizeof vis);
	queue<node> p;
	node t,tp;
	for(int i=0;i<9;i++)
		t.s[i]=i+1;
	t.x=8; 			//最终状态x在最后位置 
	t.vis=cantor(t.s);
	t.sr="";		//最终状态不需要操作 
	str[t.vis]="";	
	vis[t.vis]=1; 	//去重 
	p.push(t);	 
	while(p.size()){
		t=p.front();
		p.pop();
		for(int i=0;i<4;i++){
			int xx=t.x/3+dx[i];		//x所在位置的行和列 
			int yy=t.x%3+dy[i];
			if(xx>=0&&xx<3&&yy>=0&&yy<3){//只看在范围内的 
				tp=t;
				tp.x=xx*3+yy;		//讲行、列位置转换为在数组中的位置 
				swap(tp.s[tp.x],tp.s[t.x]);//进行移动后的交换位置 
				tp.vis=cantor(tp.s);
				if(!vis[tp.vis]){	//对没经历的状态进行操作,去重 
					vis[tp.vis]=1;	//标记 经历的状态
					tp.sr=index[i]+tp.sr; //将该状态到上一个状态的步骤加到上一个状态到终点的步骤中,就是该状态到终点的步骤 
					str[tp.vis]=tp.sr;//记录起来 
					p.push(tp);
				}
			}
		}
	} 
}
int main(){
	char s[1100];
	bfs();   //从结果开始往前走,能从结果走到的状态同样也能够走到最终状态 
	while(gets(s)){   //输入初始状态 
		int k=0;
		for(int i=0;i<strlen(s);i++){
			if(s[i]>='0'&&s[i]<='9')
				ss[k++]=s[i]-'0';
			else if(s[i]=='x')
				ss[k++]=9;
		}
		if(vis[cantor(ss)]) //如果能从结果走到初始状态就输出结果  
			cout<<str[cantor(ss)]<<endl;
		else cout<<"unsolvable"<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值