骰子涂色(Cube painting,UVa 253)

骰子涂色;

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube’s faces are numbered as in Figure 1. Since a cube has 6 faces, our machine can paint a face-numbered cube in 3 6 = 729 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a ‘b’, ‘r’, or ‘g’. The i-th character (1 ≤ i ≤ 6) from the left gives the color of face i. For example, Figure 2 is a picture of “rbgggr” and Figure 3 corresponds to “rggbgr”. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90°, the one changes into the other.

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

Output

The output is a file of boolean. For each line of input, output contains ‘TRUE’ if the second half can be obtained from the first half by rotation as describes above, ‘FALSE’ otherwise.

Sample Input

rbgggrrggbgr

rrrbbbrrbbbr

rbgrbgrrrrrg

Sample Output

TRUE

FALSE

FALSE

#include<stdio.h>
int main()
{
    char a[20];
    while(scanf("%s",&a)!=EOF){
        char x[10],y[10],t,t2; int i,j,f=1;
        for(i=0;i<12;i++){
            if(i<6) x[i]=a[i];
            else y[i-6]=a[i];
        }
        for(i=0;i<3;i++){
            if(x[i]>x[5-i]){t=x[i];x[i]=x[5-i];x[5-i]=t;}
            if(y[i]>y[5-i]){t=y[i];y[i]=y[5-i];y[5-i]=t;}
        }
        for(i=1;i<3;i++)
            for(j=2;j>=i;j--){
                if(x[j]<x[j-1]){
                    t=x[j];x[j]=x[j-1];x[j-1]=t;
                    t2=x[5-j];x[5-j]=x[6-j];x[6-j]=t2;
                }
                if(x[j]==x[j-1]&&x[5-j]<x[6-j]){
                    t2=x[5-j];x[5-j]=x[6-j];x[6-j]=t2;
                }
                if(y[j]<y[j-1]){
                    t=y[j];y[j]=y[j-1];y[j-1]=t;
                    t2=y[5-j];y[5-j]=y[6-j];y[6-j]=t2;
                }
                if(y[j]==y[j-1]&&y[5-j]<y[6-j]){
                    t2=y[5-j];y[5-j]=y[6-j];y[6-j]=t2;
                }
            }
        for(i=0;i<6;i++)
            if(x[i]!=y[i]) f=0;
        if(f) printf("TRUE\n");
        else printf("FALSE\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值