一端受限的双端队列

自己使蛮劲敲代码很愚蠢!!晴神的书一定要搞懂,大多数都是在这些基础上加一点,少变换一下!

7-2 One Way In, Two Ways Out (25 分)
Consider a special queue which is a linear structure that allows insertions at one end, yet deletions at both ends. Your job is to check, for a given insertion sequence, if a deletion sequence is possible. For example, if we insert 1, 2, 3, 4, and 5 in order, then it is possible to obtain 1, 3, 2, 5, and 4 as an output, but impossible to obtain 5, 1, 3, 2, and 4.

Input Specification:
Each input file contains one test case. For each case, the first line gives 2 positive integers N and K (≤10), which are the number of insertions and the number of queries, respectively. Then N distinct numbers are given in the next line, as the insertion sequence. Finally K lines follow, each contains N inserted numbers as the deletion sequence to be checked.

All the numbers in a line are separated by spaces.

Output Specification:
For each deletion sequence, print in a line yes if it is indeed possible to be obtained, or no otherwise.

Sample Input:
5 4
10 2 3 4 5
10 3 2 5 4
5 10 3 2 4
2 3 10 4 5
3 5 10 4 2
Sample Output:
yes
no
yes
yes

#include<bits/stdc++.h>
using namespace std;
int n, k;
vector<int> v, t, res;
vector<string> s;
int main() {
    cin >> n >> k;
    for (int i = 0; i < n; i++) {
        int temp;
        cin >> temp;
        v.push_back(temp);
    }
    s.resize(k);
    vector<int> test;
    test.resize(n);

    for (int i = 0; i < k; i++) {
        int current = 0;
        for (int j = 0; j < n; j++)
            cin >> test[j];
        for (int j = 0; j < n; j++) {
            res.push_back(v[j]);
            while (!res.empty() && (test[current] == *res.begin() || test[current] == *(res.end() - 1))) {
                if (test[current] == *res.begin()) {
                    res.erase(res.begin());
                }
                else
                    res.erase(res.end() - 1);
                current++;
            }
        }
        if (res.empty() == true) cout << "yes" << endl;
        else cout << "no" << endl;
        res.clear();
    }
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值