面向对象程序设计上机练习四(变量引用)

Problem Description
将变量的引用作为函数形参,实现2个int型数据交换。

Input
输入2个int型整数。

Output
输出2个整数交换前后的值。

Sample Input
88 66

Sample Output
88 66
66 88

AC代码:

import java.util.Scanner;

class A {
	int x, y;

	public A(int x, int y) {
		super();
		this.x = x;
		this.y = y;
	}

	public A Swap(int n, int m) {
		x = m;
		y = n;
		return new A(x, y);
	}
}

public class Main {
	public static void main(String[] args) {
		Scanner mi = new Scanner(System.in);
		A a = new A(mi.nextInt(), mi.nextInt());
		System.out.println(a.x + " " + a.y);
		a.Swap(a.x, a.y);
		System.out.println(a.x + " " + a.y);
		mi.close();
	}
}

————
余生还请多多指教!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值