Second My Problem First (单调队列入门)

https://cn.vjudge.net/problem/HDU-3706

Give you three integers n, A and B. 
Then we define S i = A i mod B and T i = Min{ S k | i-A <= k <= i, k >= 1} 
Your task is to calculate the product of T i (1 <= i <= n) mod B.

Input

Each line will contain three integers n(1 <= n <= 10 7),A and B(1 <= A, B <= 2 31-1). 
Process to end of file.

Output

For each case, output the answer in a single line.

Sample Input

1 2 3
2 3 4
3 4 5
4 5 6
5 6 7

Sample Output

2
3
4
5
6

思路:维护一个单调递增的单调队列,队首下标不符合条件就把队首出列,队尾如果值大于等于当前值就把队尾出列

#include<bits/stdc++.h>
#pragma GCC optimize(3)
using namespace std;
typedef long long ll;
struct node{
	ll x;
	int id;
};
deque<node> q;
int main(){
    int n,A,B;
    while(~scanf("%d%d%d",&n,&A,&B)){
    	q.clear();
    	ll ans=1,a=1;
    	for(int i=1;i<=n;i++){
    		a=a*A%B;
    		while(!q.empty()&&q.front().id<i-A) q.pop_front();
    		while(!q.empty()&&q.back().x>=a) q.pop_back();
    		q.push_back(node{a,i});
    		ans=ans*q.front().x%B;
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值