HDU3706-Second My Problem First

Second My Problem First

                                                                     Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                  Total Submission(s): 1813    Accepted Submission(s): 691


Problem Description
Give you three integers n, A and B. 
Then we define S i = A i mod B and T i = Min{ S k | i-A <= k <= i, k >= 1}
Your task is to calculate the product of T i (1 <= i <= n) mod B.
 

Input
Each line will contain three integers n(1 <= n <= 10 7),A and B(1 <= A, B <= 2 31-1). 
Process to end of file.
 

Output
For each case, output the answer in a single line.
 

Sample Input
  
  
1 2 3 2 3 4 3 4 5 4 5 6 5 6 7
 

Sample Output
  
  
2 3 4 5 6
 

Author
WhereIsHeroFrom@HDU
 

Source
 


题意:给你一个N A B 
Si = A^i %b,Ti =min(Sk) i-A<=k<=i k>=1,求Ti的乘积modB
解题思路:用单调队列维护i前A长度的最小值


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
#define MAXN 10000100

LL n,a,b;
int q[MAXN][2];

int main()
{
    while(~scanf("%lld %lld %lld",&n,&a,&b))
    {
        LL ans=1,x=1;
        int head=0,rear=0;
        for(int i=1;i<=n;i++)
        {
            x=x*a%b;
            while(head<rear&&i-q[head][1]>a) head++;
            while(head<rear&&q[rear-1][0]>x) rear--;
            q[rear][0]=(int)x;
            q[rear++][1]=i;
            ans=ans*q[head][0]%b;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值