Common Substrings(后缀数组+单调栈)

 https://cn.vjudge.net/problem/POJ-3415

A substring of a string T is defined as:

 

T( i, k)= TiTi +1... Ti+k -1, 1≤ ii+k-1≤| T|.

 

Given two strings A, B and one integer K, we define S, a set of triples (i, j, k):

 

S = {( i, j, k) | kK, A( i, k)= B( j, k)}.

 

You are to give the value of |S| for specific A, B and K.

Input

The input file contains several blocks of data. For each block, the first line contains one integer K, followed by two lines containing strings A and B, respectively. The input file is ended by K=0.

1 ≤ |A|, |B| ≤ 105
1 ≤ Kmin{|A|, |B|}
Characters of A and B are all Latin letters.

 

Output

For each case, output an integer |S|.

Sample Input

2
aababaa
abaabaa
1
xx
xx
0

Sample Output

22
5

题意:

给你两个长度不超过10^5的字符串A,B。和一个数字K。K<=MIN(|A|,|B|)。现在问你A,B的公共子串中长度不小于K的有多少对。位置可以重叠。

题解:https://www.cnblogs.com/Konjakmoyu/p/5678554.html

          http://www.it610.com/article/4260702.htm

https://www.cnblogs.com/lidaxin/p/5005079.html

https://blog.csdn.net/fp_hzq/article/details/9029971

 

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath> 
#include<iostream>
using namespace std;
typedef long long ll;
const int MAXN=2e5+10;
/*
*suffix array
*倍增算法  O(n*logn)
*待排序数组长度为n,放在0~n-1中,在最后面补一个0
*build_sa( ,n+1, );//注意是n+1;
*getHeight(,n);
*例如:
*n   = 8;
*num[]   = { 1, 1, 2, 1, 1, 1, 1, 2, $ };注意num最后一位为0,其他大于0
*Rank[]  = { 4, 6, 8, 1, 2, 3, 5, 7, 0 };Rank[0~n-1]为有效值,Rank[n]必定为0无效值
*sa[]    = { 8, 3, 4, 5, 0, 6, 1, 7, 2 };sa[1~n]为有效值,sa[0]必定为n是无效值
*height[]= { 0, 0, 3, 2, 3, 1, 2, 0, 1 };height[2~n]为有效值
*
*/
 
int sa[MAXN];//SA数组,表示将S的n个后缀从小到大排序后把排好序的
             //的后缀的开头位置顺次放入SA中
int t1[MAXN],t2[MAXN],c[MAXN];//求SA数组需要的中间变量,不需要赋值
int Rank[MAXN],height[MAXN];
//待排序的字符串放在s数组中,从s[0]到s[n-1],长度为n,且最大值小于m,
//除s[n-1]外的所有s[i]都大于0,r[n-1]=0
//函数结束以后结果放在sa数组中
void build_sa(int s[],int n,int m)
{
    int i,j,p,*x=t1,*y=t2;
    //第一轮基数排序,如果s的最大值很大,可改为快速排序
    for(i=0;i<m;i++)c[i]=0;
    for(i=0;i<n;i++)c[x[i]=s[i]]++;
    for(i=1;i<m;i++)c[i]+=c[i-1];
    for(i=n-1;i>=0;i--)sa[--c[x[i]]]=i;
    for(j=1;j<=n;j<<=1)
    {
        p=0;
        //直接利用sa数组排序第二关键字
        for(i=n-j;i<n;i++)y[p++]=i;//后面的j个数第二关键字为空的最小
        for(i=0;i<n;i++)if(sa[i]>=j)y[p++]=sa[i]-j;
        //这样数组y保存的就是按照第二关键字排序的结果
        //基数排序第一关键字
        for(i=0;i<m;i++)c[i]=0;
        for(i=0;i<n;i++)c[x[y[i]]]++;
        for(i=1;i<m;i++)c[i]+=c[i-1];
        for(i=n-1;i>=0;i--)sa[--c[x[y[i]]]]=y[i];
        //根据sa和x数组计算新的x数组
        swap(x,y);
        p=1;x[sa[0]]=0;
        for(i=1;i<n;i++)
            x[sa[i]]=y[sa[i-1]]==y[sa[i]] && y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;
        if(p>=n)break;
        m=p;//下次基数排序的最大值
    }
}
void getHeight(int s[],int n)
{
    int i,j,k=0;
    for(i=0;i<=n;i++) Rank[sa[i]]=i;
    for(i=0;i<n;i++)
    {
        if(k)k--;
        j=sa[Rank[i]-1];
        while(s[i+k]==s[j+k])k++;
        height[Rank[i]]=k;
    }
}
char str[MAXN];
int s[MAXN];
int q[MAXN],tot=0;
int num[MAXN];
int main()
{   
    int k;
    while(~scanf("%d",&k)&&k){
    	scanf("%s",str);
    	int f=strlen(str);
    	str[f]='$';
    	scanf("%s",str+f+1);
    	int len=strlen(str);
    	for(int i=0;i<=len;i++) s[i]=str[i];
    	build_sa(s,len+1,128);
    	getHeight(s,len);
    	tot=0;
    	ll ans=0,con=0;
    	for(int i=0;i<=len;i++){
    		printf("%d ",sa[i]);
		}
		printf("\n");
		for(int i=0;i<=len;i++){
			printf("%d ",Rank[i]);
		}
		printf("\n");
		for(int i=0;i<=len;i++){
			printf("%d ",height[i]);
		}
		printf("\n");
    	for(int i=1;i<=len;i++){
    		if(height[i]<k){
    			tot=0;
    			con=0;
			}
			else{
				int cnt=0;//统计有多少A的后缀是以height[i]为最小值的
				if(sa[i-1]<f){
					cnt++;
					con+=height[i]-k+1;
				} 
				while(tot&&height[i]<q[tot]){
					con-=(q[tot]-height[i])*num[tot];
					cnt+=num[tot];//合并点的总数
					tot--;
				}
				q[++tot]=height[i];
				num[tot]=cnt;
				if(sa[i]>f) ans+=con;
			}
		}
		tot=0,con=0;
		for(int i=1;i<=len;i++){
			if(height[i]<k){
				tot=0;
				con=0;
			}
			else{
				int cnt=0;
				if(sa[i-1]>f){
					cnt++;
					con+=height[i]-k+1;
				}
				while(tot&&height[i]<q[tot]){
					con-=(q[tot]-height[i])*num[tot];
					cnt+=num[tot];
					tot--;
				}
				q[++tot]=height[i];
				num[tot]=cnt;
				if(sa[i]<f) ans+=con;
			}
		}
		printf("%lld\n",ans);
	}
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值