String Problem (最大最小表示法模板)

https://cn.vjudge.net/problem/HDU-3374

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings: 
String Rank 
SKYLONG 1 
KYLONGS 2 
YLONGSK 3 
LONGSKY 4 
ONGSKYL 5 
NGSKYLO 6 
GSKYLON 7 
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once. 
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also. 

Input

  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input

abcder
aaaaaa
ababab

Sample Output

1 1 6 1
1 6 1 6
1 3 2 3

 

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e6+5;
char s[maxn];
int Next[maxn];
void get_Next(char s[],int len) {
	int j=-1;
	Next[0]=-1;
	for(int i=1; i<len; i++) {
		while(j!=-1&&s[i]!=s[j+1])
			j=Next[j];
		if(s[i]==s[j+1])
			j++;
		Next[i]=j;
	}
}
int get_repetend_len(int len){//循环节长度 
	return len-Next[len-1]-1;
}
int get_min(char s[]){//最小表示法 
	int len=strlen(s);
	int i=0,j=1,k=0;
	while(i<len&&j<len&&k<len){
		int t=s[(i+k)%len]-s[(j+k)%len];
		if(t==0) k++;
		else{
			if(t>0) i+=k+1;
			else j+=k+1;
			if(i==j) j++;
			k=0;
		}
	}
	return min(i,j);
}
int get_max(char s[]){//最大表示法 
    int len=strlen(s);
	int i=0,j=1,k=0;
	while(i<len&&j<len&&k<len){
		int t=s[(i+k)%len]-s[(j+k)%len];
		if(t==0) k++;
		else{
			if(t>0) j+=k+1;
			else i+=k+1;
			if(i==j) j++;
			k=0;
		}
	}
	return min(i,j);
} 
int main() {
	while(~scanf("%s",s)){
		int len=strlen(s);
		get_Next(s,len);
		int rlen=get_repetend_len(len);
		int num=1;
		if(len%rlen==0){
			num=len/rlen;
		}
		int posmin=get_min(s);
		int posmax=get_max(s);
		printf("%d %d %d %d\n",posmin+1,num,posmax+1,num);
	}
    return 0;
}
/*
//KMP算法  判断pattern是否是text的子串 
bool KMP(char text[],char pattern[]) {
    int n = strlen(text); m = strlen(pattern);
    getNext(pattern,m);    //计算pattern的Next数组 
    int j = -1;   
    for(int i = 0; i < n; i++){
        while(j != -1 && text[i] != pattern[j+1]){            
            j = Next[j];  //j回退使得满足条件或回到原点 
        }
        if(text[i] == pattern[j+1]){
            j++;   //匹配成功,j指向已匹配的最后一位             
        }
        if(j == m-1){
            return true;   //已全部匹配完成 
        }        
    } 
    return false;  //匹配结束,失败       
}
//KMP算法 统计pattern在text出现的次数  文本串“abababab”中模式串“abab”出现了3次
int KMP(char text[],char pattern[]) {
    int n = strlen(text); m = strlen(pattern);
    getNext(pattern,m); //计算pattern的Next数组
    int j = -1,ans = 0; 
    for(int i = 0; i < n; i++){
        while(j != -1 && text[i] != pattern[j+1]){
              j = Next[j]; //j回退使得满足条件或回到原点
        }
        if(text[i] == pattern[j+1]){
           j++;  //匹配成功,j指向已匹配的最后一位
        }
		if(j == m-1){
		   ans++;
		   j = Next[j];
		}
    }
    return ans;
}
*/

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值