A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
Sample Input
2 0 9 7604 24324
Sample Output
10 897
题意: 找出区间内平衡数的个数(平衡数:以这个数字的某一位为支点,另外两边的数字大小乘以力矩之和相等)
思路:枚举支点,dp[pos][x][sta],位置,支点,力矩
dp[pos][x][sta]+=dp[pos-1][x][sta+i*(pos-x)]
#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
ll dp[20][20][2000];
int a[20];
ll dfs(int pos,int x,int sta,bool limit){
if(pos==0) return sta==0;
if(!limit&&dp[pos][x][sta]!=-1) return dp[pos][x][sta];
int up=limit?a[pos]:9;
ll ans=0;
for(int i=0;i<=up;i++){
ans+=dfs(pos-1,x,sta+i*(pos-x),limit&&i==up);
}
if(!limit) return dp[pos][x][sta]=ans;
return ans;
}
ll solve(ll x){
if(x==-1) return 0;
int pos=0;
while(x){
a[++pos]=x%10;
x/=10;
}
ll ans=0;
for(int i=1;i<=pos;i++) ans+=dfs(pos,i,0,true);
return ans-pos+1;
}
int main(){
ios::sync_with_stdio(false);
cout.tie(NULL);
int T;
scanf("%d",&T);
memset(dp,-1,sizeof(dp));
while(T--){
ll x,y;
scanf("%lld%lld",&x,&y);
printf("%lld\n",solve(y)-solve(x-1));
}
return 0;
}