结构体排序HDU 5702

Sample Input
3
3
red 1
green 2
yellow 3
1
blue 83
2
red 2
white 1
Sample Output
yellow green red
blue
red white
题意:
输入一个字符串 一个数字
按照数字大小顺序输出字符。(从大到小)

#include<algorithm>
#include<cstdio>
using namespace std;
struct lkq
{
    char num[1000];
    int x;
}s[1005];
int cmp(lkq a,lkq b)
{
    return a.x>b.x;
}
int main()
{
    int t,i;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%s%d",s[i].num,&s[i].x);
        sort(s,s+n,cmp);
        for(i=0;i<n-1;i++)
        printf("%s ",s[i].num);
        printf("%s\n",s[i].num);
    }
}

int cmp(lkq a,lkq b)
{
return a.x>b.x;
}
排序数字,字符也跟着排序了。重点内容

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值