Sample Input
3
3
red 1
green 2
yellow 3
1
blue 83
2
red 2
white 1
Sample Output
yellow green red
blue
red white
题意:
输入一个字符串 一个数字
按照数字大小顺序输出字符。(从大到小)
#include<algorithm>
#include<cstdio>
using namespace std;
struct lkq
{
char num[1000];
int x;
}s[1005];
int cmp(lkq a,lkq b)
{
return a.x>b.x;
}
int main()
{
int t,i;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%s%d",s[i].num,&s[i].x);
sort(s,s+n,cmp);
for(i=0;i<n-1;i++)
printf("%s ",s[i].num);
printf("%s\n",s[i].num);
}
}
int cmp(lkq a,lkq b)
{
return a.x>b.x;
}
排序数字,字符也跟着排序了。重点内容